
UHPC-Plot release notes

2.17.1:

2.17.0:

2.16.1:

2.16.0:

Info

All software versions built and tested on MS Windows 11 64-bit (Build 26100)

Hiding first/last cycle will now no longer hide the data if there’s only one cycle
Fix for load file list retaining previously loaded data

Remember last session in plot
Popup on startup to start where you last left off (Files, Axes, and Zoom)
Save/Load Configuration will now remember the Zoom as well
Save/Load Configuration will now remember Normalization as well

Zoom no longer resets when changing Chart Settings
Cross Energy data type added

Energy relative to the start of each step

Dropdown option in Chart Settings to hide either the interpolated and final datapoints
Right Click on selected files option to “Copy Selected File(s) to new location
Expand Graph icon moved to left side to support small resolutions
Renamed Inter-Cycle Capacity Fade to Intra-Cycle Capacity Fade
Capacity Fade no longer uses absolute values
Licensing information updated
Customer Knowledge Base linked in “Help” dropdown

wh/kg units conversion error fixed

Cycle Summary Data Types Added:
Charge/Discharge Capacity Throughput



2.15.0:

2.14.0

Cumulative Capacity stored during (dis)charge per cycle

Charge/Discharge Energy Throughput
“Cumulative Energy stored during (dis)charge” or “Product of (dis)charge capacity and average
(dis)charge voltage”

Discharge Capacity Retention
Discharge capacity of a cycle divided by the discharge capacity of the previous cycle

Inter-Cycle Capacity Fade definition updated to:
The difference between the charge and discharge capacity within the same cycle

Select Cycle Number merged with the up-down cycle number arrows
When calling Export Data, can now choose to export only visible data

Example: zooming in on a graph and exporting the zoomed in data
Load File List Changes:

Load and Save File List added to bottom of UHPC file list
Fix for Load File List and Graph Preset removing all files if no file selected
.json configuration file now visible in startup choose file dialog

Notification Settings option to disable open file on startup
Removed up down arrows for file name now that drag and drop added
Alt-Tabbing with popups open should bring them to the front again when you click the main window to prevent the
main window appearing frozen
Merge Data feature now gives the correct columns so that merged files may be loaded into plot

Graph Presets:
Views renamed to Graph Presets on main page
Normalization Settings now included when saving Graph Presets
Can now save graph presets while using “Single Graph Mode”
Bug Fix: “blank” presets renamed to to ‘Nameless View’ and can now be deleted properly under Manage
Graph Presets
Bug Fix: File-> Load File List now works better, older file lists no longer default to only showing rest steps by
default
File → Save Page as Default Values now opens up Manage Graph Presets

Cumulative Energy Cell Data Axis option added
Colour Changes:

New colour palette with more choices
Batch Colouring

Right click selected datafiles “Change Colour Selected Graphs“

Choosing a custom colour is no longer transparent by default
Relabelled SDA to Transparency
Bug fixes for choosing a new colour triggering click events below mouse

Pressing Esc while zooming will cancel the zoom
Moved Default colour “Yellow” to bottom of preferred colour list
Bug Fixes Cross Capacity graph displays

The wrong offset / direction if last cycle was a half cycle
Cross Capacity is now calculated per concurrent cycle charge/discharge, pulses within a cycle will not cause
strange cross capacity behavior
Blank graph screen should no longer appear



2.13.1

2.13.0

New Single Graph View:
Can now expand any of the 4 graphs to be a single graph

Changes will persist when switching back and forth between the expanded graph, and 4 graph view

The previous “one graph per file” multi-panel functionality has been removed
Option to set Single Graph View as the new default view on load in Chart Settings
Memory Optimization mode: Can disable the 4 graph mode to only draw one graph using the single graph
view in Chart Settings.

Drag and drop reordering:
Can now drag loaded datafiles up and down to re-order them in the list

The graph colour on top is still determined by the first one to be coloured, and can be reordered by
disabling and enabling checkboxes

Relabel File Names:
Can now select one or more plotted files, and give them new names

Select and Right Click Files → Change Filename Label
If more than one file is selected, “-1”, “-2”, etc will be added after each.

Plotting Cell Data Rest steps only
Replacing “Both” “Chg” “Dis” buttons on each graph is “Charge”, “Discharge”, “Rest”

All 3 can be enabled, or any of them disabled to customize the view

Connect (or disconnect) step endpoints
The datapoints between steps will not be connected if this is unchecked
Settings → Chart Settings → Connect Step Endpoints

Hide first or last cycle data
Found in Cycle Settings

Show or hide graph gridlines
Found in Cycle Settings

Show or hide graph colour gradient
When enabled, a slight white->grey gradient applied to each graph (legacy), when disabled, the background
will be a solid white
Found in Cycle Settings

Show in Folder during file generation
When processing files on the “Save Data” page, after file generation is completed, a “Show in Folder” option
will now appear.

Fixed bug with capacity unit conversion when exporting processed data for multiple files containing different
masses when units have been changed to be based on mass.
Using the Gradient slider now works as expected
Fix for cycle summary metrics when datafile has cycle data out of order (archived snapshot, etc)

Some users have noticed the UHPC installer not removing previous versions. After installing, check Windows →
Installed Apps (or Apps and Features)→ Novonix UHPC Plot to ensure only one version remains.

Contact NOVONIX if any problems arise
Fix for Cross Capacity not normalizing properly

Normalizing and Zeroing Enhancements
Can now normalize (divide) against other cycle data types
Can now normalize each cycle against itself (using other cycle data)



Can now zero after normalizing cycle data
Can scale and shift
Axis labels (and units) now improved when normalizing and zeroing
Can normalize cell data against capacity and energy
Can normalize against cycle time in addition to other normalizing
Right click → Copy to Clipboard, and Export Image now show updated labels for normalized/zeroed axis

Cycle Summary Axis Changes
X and Y Axis now both contain the full list of types
The following axis types have been removed:

Capacity (dis)Charge Percent
Energy (dis)charge Percent
(dis)Charge Endpoint Capacity Percent
(dis)Charge Slippage Percent
Capacity Fade Percent
Zeroed (dis)Charge Endpoint Capacity

The above remove axis types can all be calculated with normalizing and zeroing functions, condensing this
helps to make a more intuitive list.
The above removed axis types can still be exported from the “save data” table

Labels updated and capitalized more consistently

dQdV and dVdQ changes
When viewing dQdV and dVdQ the step-change artifacts (such as sharp spikes) have been removed to
greatly improve readability of the datasets.

New Units: mAh/V, (Ah/g)/V, (mAh/g)/V for dQdV
New Units: mV/Ah, V/(Ah/g), mV/(Ah/g) for dVdQ

New Axis Data Types
Charge Capacity Fade and Discharge Capacity Fade added

Calculated as previous cycle (dis)charge capacity - current cycle (dis)charge capacity

Capacity Fade Changes:
Capacity Fade renamed to Inter Cycle Capacity Fade

Calculated as Charge Slippage - Discharge Slippage

Capacity Fade is now positive (Absolute Value) to match industry standard
Option to display negative values as before remains in Chart Settings → Negative Capacity Fade
checkbox

CIE per hour cell data axis removed
This can be reproduced by using Normalize By Cycle Time in the normalize settings

Save Page renamed to Export Processed Data Page for ease of use
Can now plot temperature units in Fahrenheit.
Can now plot energy as Wh/g and Wh/kg
Files to import can be dragged and dropped in plot.
Exporting Data from the main graph display will now apply cycle filters to exported data, and export
normalized/zeroed data if the data has been normalized or zeroed.

If you are graphing cycles 4-9 only cycles 4-9 will be exported

When viewing specific cycles in cell data mode (after the 1st cycle), the 1st datapoint shown is no longer the last
datapoint of the previous cycle, it is now correctly the 1st datapoint of the current cycle.
Support for future “Chamber Temperature” column

This is intended for future updates, datafiles do not yet include chamber temperature as of UHPC Control
v2.13.0



2.12.2

2.12.1

2.12.0:

2.11.0:

Chart Settings new features:
Cycle Data will now leave a gap between cycles if there’s a missing cycle between (ex: filtering)

This can be changed by checking “Connect Missing Cycles” in Chart Settings

Chart Settings now has option to ignore interpolated data points while plotting (Step Position 2)

Data Hover-Over:
Cycle data hover-over now easier to read, cycle: ## and (X,Y) data shown on a second line below file name
Cell data hover-over will now show the cycle number and file name for the highlighted dataset
This may be disabled in Settings → Chart Settings → Hide Data HoverOver

Updated micro symbol from u to μ.
example: uAh → μAh

New Icon

Fix for exception being thrown when closing UHPC Plot after opening from UHPC Control

Multiple Large file optimizations:
“Yes to All” and “No to All” options appear for Trimming large files
Loading/Refreshing/Changing Axis is now faster when using many files, visual changes occur after all data
has been (re)loaded.

Switching from the “Main View” to “Single Graph View” multiple times will no longer cause a major memory leak.
Sort alphabetical (Ascending and Descending) have been added. (Right Click → Sort: Ascending/Descending).
Lightning Chart updated to the latest version (12.0.1.1)
Migrated some data types from float to double to improve data precision
Sorted X and Y axis alphabetically

CE, CIE now labelled Coulombic Efficiency and Coulombic Inefficiency
Voltage Hysteresis and Delta V relabeled as ΔV

Tool tips have been added to axis variables.

Added a one time prompt on startup if a new version of software is available.
A new option “Settings“ has been added to menu bar.

A new option Notification settings has been added to it.
The “Chart Settings“ have been moved here.

“Views” feature has been implemented.
Users can now set the x-axis/y-axis units and save them as a view.
Users can switch seamlessly between views.
Users can Add/Remove/Override views.
Users can also set a view as “default view” which will be used when Plot is started.

Software update available pop up has been added on application start.
Request for contact info when downloading updates from software.
We can now export data when the cycles are missing in data file (any missing cycle will be skipped).
Users can now see the release notes before downloading the update (Enable software updates pop up on startup
for this feature).
Improvements to Annotation points in the UI.



2.10.0

2.9.0:

Color functionality has been improved.
Users can now set preferred colors that will be used when charts are imported.
Default colors are still present.
Users can manage the preferred colors by adding/deleting.

‘Esc’ key now closes the company details window when downloading software updates.
‘Load Configuration' and ‘Save Configuration’ on File menu options have been renamed to ‘Load file list’ and 'Save
file list’.

Popup when duplicate filenames are loaded
Discharge Slippage Percent data error corrected
Capacity Fade Percent added
Fixed bug where files removed from plot could not be reloaded
Normalization & Zeroing:

Normalization/Zero popup box added where normalization/Zero checkboxes used to be
Normalize X data option added
Zero X data option added
Normalize by Number option added
Can now normalize Cell Data (only by number, not reference cycle)

A running instance of plot can now be used to open files directly from control without opening up
Fixed bug where trimming large data files would trim too much data
“Space Bar“ key on keyboard can be used to select/deselect files.
Duplicate errors found in logs have been reduced.
“Show Cycles“ can now be configured for each file specifically by “select the file → right click → Show Cycles for
Selected Files”.
File locations can now be opened by selecting file(s) → right click → Show in folder(s).
Improved formats for error logs.
The scale for Y-axis/X-axis can now be set to Log base 10 by click “Axes” button → check/uncheck Log scale x-
axis/y-axis → Apply/Apply to All.
If the network drive connection is slow/disconnected we show a loading popup to check the drive connection on
Open files/Save files.
You can now copy the graphs to clipboard by “Right click on graph → Copy to clipboard”.
Switched to 64-bit Architecture.
Added mAh/V units to dQ/dV column.

Chart Setting of the previous version will be permanently LOST. This will only happen on first installation.
Chart Settings are moved to files.
Can now open files for displayed selected from UHPC - Control
Units are no longer sorted alphabetically, but in logical selected order

Example: Volts starts with Volts instead of mV

Fixed issue with values being converted w.r.t selected units after normalization.
When a Normalized graph is exported as image the y-axis does not show units, but “Norm=cycle_reference“ in
place of units.
Fixed a issue with data not loading properly when the cycles with no data are present.
“Delete“ key can now be used to remove the files from plot.
Left click left drag to fit data to graph can now be disabled.



2.8.0:

2.7.1:

2.7.0:

2.6.1:

2.6.0:

Right Click-> Reset Zoom is now available to fit data to graph.
Plot Normalization now works on any data on y-axis.

Coulombic Efficiency calculation configuration for anode half cells added, to allow user to flip the CE and CIE
calculations if desired.

Cycle Settings → Coulombic Efficiency Calculations: Discharge/Charge or Charge/Discharge

Fixed some bugs related to setting the Axes and users can now apply the changes to all the graphs in the Axes
dialog (Axes → Apply to All button)
The release notes are now packaged along with software (Help → Release Notes).
Renamed the “Delete File(s)“ to “Remove From List“ in the right click options for the list of files.
Fixed issue with plot color changing to white when color panel is closed without making any change.
Added new validation when setting min and max values in Axes dialog.
Fixed display bug when changing units and switching around cell data and cycle data.

Updated “Include First halfcycle” (introduced in 2.7.0) for Calculated cycles to be false by default
Fixed “Cycle Error” prompt not correctly using Calculated cycles if user reloaded data.
Fixed “Save Page” view to properly use the selected cycle type (Incremented or calculated)
Added “Do not show me again” checkbox for the “Add NOVONIX cycles..” prompt when loading files without
increment cycle. Also added this checkbox in cycle configuration to enable and disable this prompt.
Zeroed capacity column calculation errors in save files have been fixed.

Added a “Cycle Settings” button to allow the user to switch between datafile Increment Cycle counter, and
calculated (NOVONIX) cycles

Option to use Charge Discharge OR Discharge charge
Option to include the first half cycle in the first cycle
Configuration saved between sessions

Improvements made to cycle summary calculations
No longer prompted of possible cycle errors on data file load unnecessarily

Only prompted that your data file may have cycle issues error popup if:
You only have one cycle in your datafile
You’re using datafile cycles not calculated cycles
There are more than 2 calculated cycles

When exporting data from main screen, datafiles with different numbers of cycles won’t impact the export results of
other datafiles
Fixed bug that could prevent graphs from loading if “cycle data” or “cell data” defaults had been changed

Fixed issue related to log spamming and performance while importing certain files.

Error string displayed if errors occur during “Save Page” data generation
Rare error with 12th gen intel chipsets causing graphs not to appear on launch resolved
Contact us button added containing customer support email added to Help dropdown



2.5.1:

2.5.0:

2.4.1:

2.4.0:

2.3.0.5:

2.3.0.4:

Checks for software updates when the application starts and “Download update“ button will be shown if a new
version is available.

Adding 3rd party plugin licensing information

Save File - Generate Data functionality rework
Fixed the column selected exporting wrong data / labels
Fixed Save Setup as Default button to properly save and load preferences
Merged Summary Cycle/Time tables and given user preference on which is included (time or cycle)
Added DetailedVQ table to select detailed V, Q, DV, DQ output information
Added option for user to combine or separate selected datafiles export data
Added option for user to combine or separate selected traits when generating data
Updating naming convention for output files to better match displayed
Output Change:

Updated generated data headers to include file name in first row/column
Updated generated data headers to include column names
DetailedPreset export data format remains unchanged

Updated the plot axis to show units for all types of data (like dv/dq , capacity, etc)
The Error logs will now be stored in c:\Novonix\UHPC Log Files\ErrorLogs\

Fixed file dropdown not opening applications using new installer
Fixed dd-MMM-yyyy timestamps not loading data files
Switched to standard yyyy-MM-dd format
Some optimizations to datafile reading

Updated to latest Novonix Graphic
Added regional support to prevent language issues
fixed issue where exporting a single cycle’s data resulted in the wrong (always 1st cycle) export data
Including .NET framework in latest installer

Renamed from HPC Plot to UHPC Plot
Added Novonix11 type datafile
Added support for UHPC Control 2.4.1 data files

Normalization and Zeroing fixes
Update button added to recalculate if plot isn’t updating after a field change
Fixed issue with columns not using Percentage Columns correctly
Minor UI changes
Changes to drop down colour picker
Turned off Colour on Plot name line



2.3.0.3

Changed file size from 500,000 to 100,000 data points before pop-up appears offering to trim data, so
optimizations can be offered sooner

Fixed issue exporting graph with uneven cycle numbers

Info

The latest version of each software package is available for download in the NOVONIX Customer Area

https://www.novonixgroup.com/customer-area/

